Author Topic: cb|Emailogin 0.3  (Read 34862 times)

codebirth

  • Administrator
  • *
  • Posts: 36
    • View Profile
    • c o d e b i r t h
cb|Emailogin 0.3
« on: December 22, 2009, 09:01:07 PM »
cb|Emailogin 0.3

This MOD will force your forum members to login using their email address instead of username. This behaviour can be useful in many situations.

The package will also change some language strings to adapt to the new behaviour.

Compatible with SMF versions 1.1.11, 2.0 RC2

IMPORTANT: This MOD may not be compatible with previous SMF versions.


Changelog
============

0.3

  • Added compatibility with SMF 1.1.11 and 2.0 RC2, and so with the new Curve theme

0.2

  • Added compatibility with SMF 1.1.10 and 2.0 RC1.2
  • Fixed some glitches when login forced on unauthorized boards and on maintenance mode

0.1.a

  • Added compatibility with SMF 1.1.8

0.1

  • Initial release for SMF 2.0 RC1
« Last Edit: January 17, 2010, 09:15:26 PM by codebirth »
c o d e b i r t h

codebirth

  • Administrator
  • *
  • Posts: 36
    • View Profile
    • c o d e b i r t h
Re: cb|Emailogin 0.3
« Reply #1 on: July 22, 2010, 09:29:29 PM »
cb|Emailogin 0.4 for SMF 2.0 RC3 now available  8)
c o d e b i r t h

Mastadd

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: cb|Emailogin 0.3
« Reply #2 on: February 21, 2011, 03:14:05 AM »
Hi Guys,

Sorry to Bump up an old Thread,

We're using SMF 2.0 RC2
and trying to install your .3 Version to slow the stem of BOT attempts at logging in,

But im getting some faults up its only with the Language package from what i can tell

Execute Modification    

./Themes/default/languages/index.spanish_es-utf8.php    Test failed
      1.    Replace    ./Themes/default/languages/index.spanish_es-utf8.php    Test successful
      2.    Replace    ./Themes/default/languages/index.spanish_es-utf8.php    Test failed


13.    Execute Modification
   ./Themes/default/languages/Login.english-utf8.php    Test failed
      1.    Replace    ./Themes/default/languages/Login.english-utf8.php    Test failed

14.    Execute Modification    
./Themes/default/languages/Login.spanish_es-utf8.php    Test failed
      1.    Replace    ./Themes/default/languages/Login.spanish_es-utf8.php    Test failed
      2.    Add Before    ./Themes/default/languages/Login.spanish_es-utf8.php    Test success

16.    Execute Modification
   ./Themes/default/languages/Profile.english-utf8.php    Test failed
      1.    Replace    ./Themes/default/languages/Profile.english-utf8.php    Test successful
      2.    Replace    ./Themes/default/languages/Profile.english-utf8.php    Test failed

I wouldn't worry about the Spanish errors but its the English ones that worry me the most

codebirth

  • Administrator
  • *
  • Posts: 36
    • View Profile
    • c o d e b i r t h
Re: cb|Emailogin 0.3
« Reply #3 on: February 22, 2011, 10:39:57 AM »
Hi Mastadd,

This is probably caused because the language strings on your language files are different from the original language strings on those language packages.

From the code you pasted it seems Spanish_ES UTF8 and English UTF8 can't install properly, but English ISO-8859-1, which is the default language package, seems to be installing fine. If you can check that your forum is using the English ISO package and the modification for this language will be executed properly it should be fine to proceed with the install.

If not, let me know and we'll find an alternative.
c o d e b i r t h

codebirth

  • Administrator
  • *
  • Posts: 36
    • View Profile
    • c o d e b i r t h
Re: cb|Emailogin 0.3
« Reply #4 on: March 05, 2011, 11:31:04 AM »
Hi steve,

Yes, send me a PM please.

Thank you.
c o d e b i r t h